<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">
		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="pingback" href="https://www.centraltrack.com/xmlrpc.php">

		
		<!-- head extras -->
		<title>The Biggest Dallas Asshats Of 2020. | Central Track</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* alerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }

	/* Custom CSS */
	.bsaProContainer-7 { margin: 0 auto; max-width: 970px; }
.bsaProContainer-6 { margin: 0 auto; max-width: 728px; }
.bsaProContainer-8 { margin: 0 auto; max-width: 254px; }
.bsaProContainer-9 { margin: 0 auto; max-width: 300px; }
.bsaProContainer-11 { margin: 0 auto; max-width: 300px; }
.bsaProContainer-13 { margin: 0 auto; }
</style>
<!-- This site is optimized with the Yoast SEO Premium plugin v12.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="After A Year That Packed A Month Of Suffering Into Each Week, Here&#039;s A List Of 13 Jerks Who Made 2020 Particularly Obnoxious &amp; Terrible For North Texans."/>
<meta name="news_keywords" content="asshats of dallas, central track asshats of the year, dallas asshats of the year, worst people in dallas, worst things about dallas, dallas" />
<meta name="original-source" content="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Biggest Dallas Asshats Of 2020. | Central Track" />
<meta property="og:description" content="After A Year That Packed A Month Of Suffering Into Each Week, Here&#039;s A List Of 13 Jerks Who Made 2020 Particularly Obnoxious &amp; Terrible For North Texans." />
<meta property="og:url" content="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" />
<meta property="og:site_name" content="Central Track" />
<meta property="article:publisher" content="https://www.facebook.com/CentralTracker" />
<meta property="article:tag" content="asshats of dallas" />
<meta property="article:tag" content="central track asshats of the year" />
<meta property="article:tag" content="dallas asshats of the year" />
<meta property="article:tag" content="worst people in dallas" />
<meta property="article:tag" content="worst things about dallas" />
<meta property="article:section" content="Culture" />
<meta property="article:published_time" content="2020-12-22T10:30:32-06:00" />
<meta property="article:modified_time" content="2020-12-22T05:36:21-06:00" />
<meta property="og:updated_time" content="2020-12-22T05:36:21-06:00" />
<meta property="og:image" content="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg" />
<meta property="og:image:secure_url" content="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="944" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="After A Year That Packed A Month Of Suffering Into Each Week, Here&#039;s A List Of 13 Jerks Who Made 2020 Particularly Obnoxious &amp; Terrible For North Texans." />
<meta name="twitter:title" content="The Biggest Dallas Asshats Of 2020. | Central Track" />
<meta name="twitter:site" content="@Central_Track" />
<meta name="twitter:image" content="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg" />
<meta name="twitter:creator" content="@alex_j_gaskin" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.centraltrack.com/#organization","name":"Central Track","url":"https://www.centraltrack.com/","sameAs":["https://www.facebook.com/CentralTracker","https://www.instagram.com/centraltrack/","https://www.youtube.com/centraltracker","https://twitter.com/Central_Track"],"logo":{"@type":"ImageObject","@id":"https://www.centraltrack.com/#logo","url":"https://www.centraltrack.com/wp-content/uploads/2016/07/CentralTrack_circle_logo.png","width":1000,"height":1000,"caption":"Central Track"},"image":{"@id":"https://www.centraltrack.com/#logo"}},{"@type":"WebSite","@id":"https://www.centraltrack.com/#website","url":"https://www.centraltrack.com/","name":"Central Track","publisher":{"@id":"https://www.centraltrack.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.centraltrack.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#primaryimage","url":"https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg","width":1200,"height":944},{"@type":"WebPage","@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#webpage","url":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/","inLanguage":"en-US","name":"The Biggest Dallas Asshats Of 2020. | Central Track","isPartOf":{"@id":"https://www.centraltrack.com/#website"},"primaryImageOfPage":{"@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#primaryimage"},"datePublished":"2020-12-22T10:30:32-06:00","dateModified":"2020-12-22T05:36:21-06:00","description":"After A Year That Packed A Month Of Suffering Into Each Week, Here's A List Of 13 Jerks Who Made 2020 Particularly Obnoxious & Terrible For North Texans."},{"@type":"Article","@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#article","isPartOf":{"@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#webpage"},"author":{"@id":"https://www.centraltrack.com/#/schema/person/9ef7dcd2ed47dee6c5b5e977212252d3"},"headline":"The Biggest Dallas Asshats Of 2020.","datePublished":"2020-12-22T10:30:32-06:00","dateModified":"2020-12-22T05:36:21-06:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#webpage"},"publisher":{"@id":"https://www.centraltrack.com/#organization"},"image":{"@id":"https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/#primaryimage"},"keywords":"asshats of dallas,central track asshats of the year,dallas asshats of the year,worst people in dallas,worst things about dallas","articleSection":"Culture"},{"@type":["Person"],"@id":"https://www.centraltrack.com/#/schema/person/9ef7dcd2ed47dee6c5b5e977212252d3","name":"Alex Gaskin","image":{"@type":"ImageObject","@id":"https://www.centraltrack.com/#authorlogo","url":"https://secure.gravatar.com/avatar/10033ce5a7e39632b6c7c4b9821637b8?s=96&d=mm&r=g","caption":"Alex Gaskin"},"description":"Alex Gaskin is a writer and standup comic in Dallas, TX. His writing has appeared in Central Track, Irish Film Critic, and Dallas Entertainment Journal. He's performed standup at comedy clubs, bars, a convenience store (twice), and comedy festivals. He interviews other Dallas comics for Central Track's Humor Us series. Find his Twitter self at @alex_j_gaskin.","sameAs":["https://twitter.com/alex_j_gaskin"]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//js.hs-scripts.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Central Track &raquo; Feed" href="https://www.centraltrack.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Central Track &raquo; Comments Feed" href="https://www.centraltrack.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Central Track &raquo; The Biggest Dallas Asshats Of 2020. Comments Feed" href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.12.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-28037092-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-28037092-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->

        <!-- MonsterInsights Ads Tracking -->
        <script type="text/javascript" data-cfasync="false">
			window.google_analytics_uacct = 'UA-28037092-3';

        </script>
        <!-- End MonsterInsights Ads Tracking -->
		
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.centraltrack.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='login-with-ajax-css'  href='https://www.centraltrack.com/wp-content/themes/15zine/plugins/login-with-ajax/widget.css?ver=3.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.centraltrack.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.4' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wc-block-vendors-style-css'  href='https://www.centraltrack.com/wp-content/plugins/woo-gutenberg-products-block/build/vendors-style.css?ver=3.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://www.centraltrack.com/wp-content/plugins/woo-gutenberg-products-block/build/style.css?ver=3.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/style.css?v=4.3.2&#038;ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/user-panel.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/all.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/animate.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/chart.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_carousel_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/bsa.carousel.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/material-design.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.centraltrack.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='yop-public-css'  href='https://www.centraltrack.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.1.9.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='https://www.centraltrack.com/wp-content/themes/15zine/library/css/style.min.css?ver=3.2.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cb-font-stylesheet-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7COpen+Sans%3A400%2C700%2C400italic&#038;ver=3.2.2' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://www.centraltrack.com/wp-content/themes/15zine/library/css/ie.css?ver=3.2.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='cb-woocommerce-stylesheet-css'  href='https://www.centraltrack.com/wp-content/themes/15zine/woocommerce/css/woocommerce.css?ver=3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb-child-main-stylesheet-css'  href='https://www.centraltrack.com/wp-content/themes/15zine-child/style.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.centraltrack.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.9.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/www.centraltrack.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/themes/15zine/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.centraltrack.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/google-analytics-premium/assets/js/frontend.min.js?ver=7.12.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.centraltrack.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/shortcode.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-admin/js/media-upload.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/script.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/chart.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/bsa.carousel.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=5.4.4'></script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?render=explicit&onload=YOPPollOnLoadRecaptcha'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/themes/15zine/library/js/modernizr.custom.min.js?ver=2.6.2'></script>
<link rel='https://api.w.org/' href='https://www.centraltrack.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.centraltrack.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.centraltrack.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.4" />
<meta name="generator" content="WooCommerce 4.5.2" />
<link rel='shortlink' href='https://wp.me/p7KGo3-VVs' />
<link rel="alternate" type="application/json+oembed" href="https://www.centraltrack.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.centraltrack.com%2Fthe-biggest-dallas-asshats-of-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.centraltrack.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.centraltrack.com%2Fthe-biggest-dallas-asshats-of-2020%2F&#038;format=xml" />
			<!-- DO NOT COPY THIS SNIPPET! Start of Page Analytics Tracking for HubSpot WordPress plugin v7.43.4-->
			<script type="text/javascript">
				var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);
			</script>
			<!-- DO NOT COPY THIS SNIPPET! End of Page Analytics Tracking for HubSpot WordPress plugin -->
						<script>
				(function() {
					var formObjects = [];
					window.hbsptReady = function(formObject) {
						if (!formObject) {
							for (var i in formObjects) {
								hbspt.forms.create(formObjects[i]);
							};
							formObjects = [];
						} else if (window.hbspt && window.hbspt.forms) {
							hbspt.forms.create(formObject);
						} else {
							formObjects.push(formObject);
						}
					};
				})();
			</script>
		<style type='text/css'>img#wpstats{display:none}</style><!-- Mailchimp Pop Up -->
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/7b51aa144fe7980392eaae011/d3d98d2531a452442b7e1ff5c.js");</script>
<!-- End Mailchimp Pop Up -->

<!-- IDKDA Pixel Code -->
<img src="https://one.progmxs.com/seg?add=23463374&t=2" width="1" height="1" />

<script src="https://one.progmxs.com/seg?add=23463374&t=1" type="text/javascript"></script>
<!-- End IDFKA Pixel Code -->

<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '917839732047032');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=917839732047032&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<style type="text/css"><!--.wpcf7 
{
 margin: 0px 0;
    margin-top: 0px;
    margin-right: 0px;
    margin-bottom: 0px;
    margin-left: 0px;
}
-->#cb-nav-bar .cb-mega-menu-columns .cb-sub-menu > li > a { color: #ffffff; } .cb-entry-content a {color:#8224e3; }.cb-review-box .cb-bar .cb-overlay span { background: #f9db32; }.cb-review-box i { color: #f9db32; }.cb-review-box .cb-bar .cb-overlay span { background: #6d30c6; }.cb-review-box i { color: #6d30c6; }.cb-meta-style-1 .cb-article-meta { background: rgba(0, 0, 0, 0.25); }.cb-module-block .cb-meta-style-2 img, .cb-module-block .cb-meta-style-4 img, .cb-grid-x .cb-grid-img img, .cb-grid-x .cb-grid-img .cb-fi-cover  { opacity: 0.75; }@media only screen and (min-width: 768px) {
                .cb-module-block .cb-meta-style-1:hover .cb-article-meta { background: rgba(0, 0, 0, 0.75); }
                .cb-module-block .cb-meta-style-2:hover img, .cb-module-block .cb-meta-style-4:hover img, .cb-grid-x .cb-grid-feature:hover img, .cb-grid-x .cb-grid-feature:hover .cb-fi-cover, .cb-slider li:hover img { opacity: 0.25; }
            }.cb-header { background-color: #000000; }</style><!-- end custom css --><style type="text/css">body, #respond, .cb-font-body { font-family: 'Open Sans', sans-serif; } h1, h2, h3, h4, h5, h6, .cb-font-header, #bbp-user-navigation, .cb-byline{ font-family:'Montserrat', sans-serif; }</style>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '354900578421186', {}, {
    "agent": "wordpress-5.4.4-2.2.0"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=354900578421186&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<!-- There is no amphtml version available for this URL. --><style>.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-154:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-154:focus { background:#00a69c !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-154 .cb-big-menu { border-top-color: #00a69c; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-114939:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-114939:focus { background:#cc6b16 !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-114939 .cb-big-menu { border-top-color: #cc6b16; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-153:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-153:focus { background:#ce1595 !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-153 .cb-big-menu { border-top-color: #ce1595; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-530:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-530:focus { background:#85a130 !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-530 .cb-big-menu { border-top-color: #85a130; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-160:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-160:focus { background:#6d30c6 !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-160 .cb-big-menu { border-top-color: #6d30c6; }</style><link rel="icon" href="https://www.centraltrack.com/wp-content/uploads/2015/03/CT-Favicon-16x16.png" sizes="32x32" />
<link rel="icon" href="https://www.centraltrack.com/wp-content/uploads/2015/03/CT-Favicon-16x16.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.centraltrack.com/wp-content/uploads/2015/03/CT-Favicon-16x16.png" />
<meta name="msapplication-TileImage" content="https://www.centraltrack.com/wp-content/uploads/2015/03/CT-Favicon-16x16.png" />
 
		<!-- end head extras -->




	</head>

	<body data-rsssl=1 class="post-template-default single single-post postid-222670 single-format-standard theme-15zine woocommerce-no-js  cb-sticky-mm  cb-tm-dark cb-body-light cb-menu-dark cb-mm-dark cb-footer-dark   cb-m-logo-off cb-m-sticky cb-sw-tm-fw cb-sw-header-fw cb-sw-menu-fw cb-sw-footer-fw cb-menu-al-left  cb-fis-b-parallax cb-fis-big-block cb-fis-big-border  cb-fis-tl-overlay">

		
		<div id="cb-outer-container">

			
				<div id="cb-top-menu" class="clearfix cb-font-header ">
					<div class="wrap clearfix cb-site-padding cb-top-menu-wrap">

													<div class="cb-left-side cb-mob">

								<a href="#" id="cb-mob-open" class="cb-link"><i class="fa fa-bars"></i></a>
															</div>
						                        <ul class="cb-top-nav cb-left-side"><li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.centraltrack.com/about/">About</a></li>
<li id="menu-item-159081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159081"><a href="https://www.centraltrack.com/advertise/">Advertise</a></li>
<li id="menu-item-159080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159080"><a href="https://www.centraltrack.com/contact/">Contact</a></li>
<li id="menu-item-176792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176792"><a href="https://www.centraltrack.com/email-list/">Join Our Email List</a></li>
</ul>                                                <ul class="cb-top-nav cb-right-side"><li class="cb-icon-search cb-menu-icons-extra"><a href="#"  title="Search" id="cb-s-trigger-gen"><i class="fa fa-search"></i> <span class="cb-search-title">Search</span></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="https://www.twitter.com/Central_Track" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="https://www.facebook.com/CentralTracker" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="https://www.instagram.com/centraltrack/" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a></li></ul>					</div>
				</div>

				<div id="cb-mob-menu" class="cb-mob-menu">
					<div class="cb-mob-close-wrap">
						
						<a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>
						<div class="cb-mob-social">				            <a href="https://www.twitter.com/https://twitter.com/Central_Track" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
				        				            <a href="https://www.facebook.com/https://www.facebook.com/CentralTracker" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
				        				            <a href="https://www.instagram.com/https://www.instagram.com/centraltrack/" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a>
				        </div>				    </div>

					<div class="cb-mob-menu-wrap">
						<ul id="cb-mob-ul" class="cb-mobile-nav cb-top-nav cb-mob-ul-show"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-154"><a href="https://www.centraltrack.com/category/music/">Music</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-205"><a href="https://www.centraltrack.com/category/music/white-noise/">White Noise</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219740"><a href="https://www.centraltrack.com/category/music/spicys-soundtrack/">Spicy&#8217;s Soundtrack</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120493"><a href="https://www.centraltrack.com/category/music/song-of-the-day/">Song of the Day</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120495"><a href="https://www.centraltrack.com/category/music/concert-reviews/">Concert Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182143"><a href="https://www.centraltrack.com/category/music/just-announced/">Just Announced</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-114939"><a href="https://www.centraltrack.com/category/food-and-drinks/">Food + Drinks</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-544"><a href="https://www.centraltrack.com/category/food-and-drinks/bar-raised/">Bar Raised</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219739"><a href="https://www.centraltrack.com/category/food-and-drinks/the-cocktease-food-and-drinks/">The Cocktease</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-546"><a href="https://www.centraltrack.com/category/food-and-drinks/the-spread/">The Spread</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-545"><a href="https://www.centraltrack.com/category/food-and-drinks/on-tap/">On Tap</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131192"><a href="https://www.centraltrack.com/category/food-and-drinks/look-at-this-fucking-dish/">Look At This Fucking Dish</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-153"><a href="https://www.centraltrack.com/category/nightlife/">Nightlife + Fashion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-541"><a href="https://www.centraltrack.com/category/nightlife/party-pics/">Party Pics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://www.centraltrack.com/category/nightlife/street-style/">Street Style</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-530"><a href="https://www.centraltrack.com/category/film/">TV + Film</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-538"><a href="https://www.centraltrack.com/category/film/coming-attractions/">Coming Attractions</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-539"><a href="https://www.centraltrack.com/category/film/film-reviews/">Film Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children cb-has-children menu-item-160"><a href="https://www.centraltrack.com/category/culture/">Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204923"><a href="https://www.centraltrack.com/category/culture/things-to-do/">Things To Do</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120498"><a href="https://www.centraltrack.com/category/culture/forechecking/">Forechecking</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-548"><a href="https://www.centraltrack.com/category/culture/asshat-of-the-week/">Asshat of the Week</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120499"><a href="https://www.centraltrack.com/category/culture/humor-us/">Humor Us</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204922"><a href="https://www.centraltrack.com/category/culture/dtx-selects/">DTX Selects</a></li>
</ul>
</li>
</ul>											</div>

				</div>
			
			<div id="cb-container" class="clearfix" >
									<header id="cb-header" class="cb-header  cb-with-block ">

					    <div id="cb-logo-box" class="cb-logo-left wrap">
	                    	                <div id="logo">
                                        <a href="https://www.centraltrack.com">
                        <img src="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-WebLogoWhite2.png" alt="Central Track logo" data-at2x="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-WebLogoWhite-retina.png">
                    </a>
                                    </div>
            	                        <div class="cb-large cb-block"><div id="bsa-block-728--90" class="bsaProContainerNew bsaProContainer-6 bsa-block-728--90 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=6&bsa_pro_id=1177&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bsa-pro-upload/1592522030-BentonWilliams_1456x180.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "6";
					var object = $(".bsaProContainer-" + sid);
					var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "728";
					var parentHeight = "90";
					var objectWidth = object.parent().outerWidth();
//					var objectWidth = object.width();
					if ( objectWidth <= parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							imageThumb.height(parentHeight * scale);
//							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
//							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						imageThumb.height(parentHeight);
//						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-6 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-6');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						</div>	                    </div>

					</header>
				
				<div id="cb-lwa" class="cb-lwa-modal cb-modal"><div class="cb-close-m cb-ta-right"><i class="fa cb-times"></i></div>
<div class="cb-lwa-modal-inner cb-modal-inner cb-light-loader cb-pre-load cb-font-header clearfix">
    <div class="lwa lwa-default clearfix">
                
        

        <form class="lwa-form cb-form cb-form-active clearfix" action="https://www.centraltrack.com/wp-login.php" method="post">
            
            <div class="cb-form-body">
                <input class="cb-form-input cb-form-input-username" type="text" name="log" placeholder="Username">
                <input class="cb-form-input" type="password" name="pwd" placeholder="Password">
                                <span class="lwa-status cb-ta-center"></span>
                <div class="cb-submit cb-ta-center">
                  <input type="submit" name="wp-submit" class="lwa_wp-submit cb-submit-form" value="Log In" tabindex="100" />
                  <input type="hidden" name="lwa_profile_link" value="" />
                  <input type="hidden" name="login-with-ajax" value="login" />
                </div>

                <div class="cb-remember-me cb-extra cb-ta-center"><label>Remember Me</label><input name="rememberme" type="checkbox" class="lwa-rememberme" value="forever" /></div>
                
                <div class="cb-lost-password cb-extra cb-ta-center">
                                          <a class="lwa-links-remember cb-title-trigger cb-trigger-pass" href="https://www.centraltrack.com/wp-login.php?action=lostpassword" title="Lost your password?">Lost your password?</a>
                                     </div>
           </div>
        </form>
        
                <form class="lwa-remember cb-form clearfix" action="https://www.centraltrack.com/wp-login.php?action=lostpassword" method="post">

            <div class="cb-form-body">

                <input type="text" name="user_login" class="lwa-user-remember cb-form-input" placeholder="Enter username or email">
                                <span class="lwa-status cb-ta-center"></span>

                 <div class="cb-submit cb-ta-center">
                        <input type="submit" value="Get New Password" class="lwa-button-remember cb-submit-form" />
                        <input type="hidden" name="login-with-ajax" value="remember" />
                 </div>
            </div>

        </form>
            </div>
</div></div><div id="cb-menu-search" class="cb-s-modal cb-modal"><div class="cb-close-m cb-ta-right"><i class="fa cb-times"></i></div><div class="cb-s-modal-inner cb-pre-load cb-light-loader cb-modal-inner cb-font-header cb-mega-three cb-mega-posts clearfix"><form method="get" class="cb-search" action="https://www.centraltrack.com/">

    <input type="text" class="cb-search-field cb-font-header" placeholder="Search.." value="" name="s" title="" autocomplete="off">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>
    
</form><div id="cb-s-results"></div></div></div>				
									 <nav id="cb-nav-bar" class="clearfix ">
					 	<div class="cb-nav-bar-wrap cb-site-padding clearfix cb-font-header  cb-menu-fw">
		                    <ul class="cb-main-nav wrap clearfix"><li id="menu-item-154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-154"><a href="https://www.centraltrack.com/category/music/">Music</a><div class="cb-menu-drop cb-bg cb-mega-menu cb-big-menu clearfix"><div class="cb-sub-mega-three cb-pre-load cb-mega-posts  clearfix"><div class="cb-upper-title"><h2>Music</h2><a href="https://www.centraltrack.com/category/music/" class="cb-see-all">See all</a></div><ul class="cb-sub-posts"> <li class="cb-looper cb-article-1 cb-mm-posts-count-3 cb-style-1 clearfix post-222643 post type-post status-publish format-standard has-post-thumbnail category-music category-song-of-the-day"><div class="cb-mask cb-img-fw" style="background-color: #00a69c;"><a href="https://www.centraltrack.com/song-of-the-day-the-avalanches-interstellar-love-feat-leon-bridges/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/song-of-the-day-the-avalanches-interstellar-love-feat-leon-bridges/">Song Of The Day: The Avalanches – &#8220;Interstellar Love Feat. Leon Bridges&#8221;</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div></div></li> <li class="cb-looper cb-article-2 cb-mm-posts-count-3 cb-style-1 clearfix post-222599 post type-post status-publish format-standard has-post-thumbnail category-music tag-bts tag-bts-2020-tour tag-bts-2021-tour tag-bts-army tag-bts-army-dallas tag-bts-dallas tag-bts-map-of-the-soul-tour tag-bts-tour tag-concerts-dallas-missed-2020"><div class="cb-mask cb-img-fw" style="background-color: #00a69c;"><a href="https://www.centraltrack.com/12-dallas-concerts-were-sad-we-missed-in-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/BTS-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/BTS-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/BTS-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/BTS-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/12-dallas-concerts-were-sad-we-missed-in-2020/">12 Dallas Concerts We&#8217;re Sad We Missed In 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 21, 2020</time></span></div></div></li> <li class="cb-looper cb-article-3 cb-mm-posts-count-3 cb-style-1 clearfix post-222250 post type-post status-publish format-standard has-post-thumbnail category-culture category-music category-song-of-the-day tag-atatiana-jefferson tag-jeff-dazey-central-track"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/">Song Of The Day: Jeff Dazey &#8211; &#8220;Song for Atatiana Ft. Greyhounds&#8221;</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-21">December 21, 2020</time></span></div></div></li></ul></div><ul class="cb-sub-menu cb-sub-bg">	<li id="menu-item-205" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-205"><a href="https://www.centraltrack.com/category/music/white-noise/" data-cb-c="13" class="cb-c-l">White Noise</a></li>
	<li id="menu-item-219740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219740"><a href="https://www.centraltrack.com/category/music/spicys-soundtrack/" data-cb-c="72307" class="cb-c-l">Spicy&#8217;s Soundtrack</a></li>
	<li id="menu-item-120493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120493"><a href="https://www.centraltrack.com/category/music/song-of-the-day/" data-cb-c="8" class="cb-c-l">Song of the Day</a></li>
	<li id="menu-item-120495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120495"><a href="https://www.centraltrack.com/category/music/concert-reviews/" data-cb-c="520" class="cb-c-l">Concert Reviews</a></li>
	<li id="menu-item-182143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182143"><a href="https://www.centraltrack.com/category/music/just-announced/" data-cb-c="49460" class="cb-c-l">Just Announced</a></li>
</ul></div></li>
<li id="menu-item-114939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-114939"><a href="https://www.centraltrack.com/category/food-and-drinks/">Food + Drinks</a><div class="cb-menu-drop cb-bg cb-mega-menu cb-big-menu clearfix"><div class="cb-sub-mega-three cb-pre-load cb-mega-posts  clearfix"><div class="cb-upper-title"><h2>Food + Drinks</h2><a href="https://www.centraltrack.com/category/food-and-drinks/" class="cb-see-all">See all</a></div><ul class="cb-sub-posts"> <li class="cb-looper cb-article-1 cb-mm-posts-count-3 cb-style-1 clearfix post-222719 post type-post status-publish format-standard has-post-thumbnail category-food-and-drinks category-the-cocktease-food-and-drinks tag-krio-bishop-arts tag-krio-dallas tag-krio-dallas-cocktails tag-milk-punch-krio tag-the-cocktease"><div class="cb-mask cb-img-fw" style="background-color: #cc6b16;"><a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/">The Cocktease: The Milk Punch at Krio.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div></div></li> <li class="cb-looper cb-article-2 cb-mm-posts-count-3 cb-style-1 clearfix post-222621 post type-post status-publish format-standard has-post-thumbnail category-food-and-drinks category-nightlife tag-bars-that-opened-in-pandemic tag-best-new-bars-central-track tag-dallas-best-new-bars tag-dallas-best-new-bars-2020"><div class="cb-mask cb-img-fw" style="background-color: #cc6b16;"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/">The Best New Dallas Bars Of 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div></div></li> <li class="cb-looper cb-article-3 cb-mm-posts-count-3 cb-style-1 clearfix post-222419 post type-post status-publish format-standard has-post-thumbnail category-culture category-food-and-drinks category-music category-nightlife tag-2020-dallas-closures tag-saddest-closures tag-saddest-dallas-closures tag-this-year-sucked-ass"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/the-saddest-closures-of-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-saddest-closures-of-2020/">The Saddest Dallas Business Closures Of 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-18">December 17, 2020</time></span></div></div></li></ul></div><ul class="cb-sub-menu cb-sub-bg">	<li id="menu-item-544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-544"><a href="https://www.centraltrack.com/category/food-and-drinks/bar-raised/" data-cb-c="42" class="cb-c-l">Bar Raised</a></li>
	<li id="menu-item-219739" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219739"><a href="https://www.centraltrack.com/category/food-and-drinks/the-cocktease-food-and-drinks/" data-cb-c="78116" class="cb-c-l">The Cocktease</a></li>
	<li id="menu-item-546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-546"><a href="https://www.centraltrack.com/category/food-and-drinks/the-spread/" data-cb-c="45" class="cb-c-l">The Spread</a></li>
	<li id="menu-item-545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-545"><a href="https://www.centraltrack.com/category/food-and-drinks/on-tap/" data-cb-c="44" class="cb-c-l">On Tap</a></li>
	<li id="menu-item-131192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131192"><a href="https://www.centraltrack.com/category/food-and-drinks/look-at-this-fucking-dish/" data-cb-c="565" class="cb-c-l">Look At This Fucking Dish</a></li>
</ul></div></li>
<li id="menu-item-153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-153"><a href="https://www.centraltrack.com/category/nightlife/">Nightlife + Fashion</a><div class="cb-menu-drop cb-bg cb-mega-menu cb-big-menu clearfix"><div class="cb-sub-mega-three cb-pre-load cb-mega-posts  clearfix"><div class="cb-upper-title"><h2>Nightlife + Fashion</h2><a href="https://www.centraltrack.com/category/nightlife/" class="cb-see-all">See all</a></div><ul class="cb-sub-posts"> <li class="cb-looper cb-article-1 cb-mm-posts-count-3 cb-style-1 clearfix post-222621 post type-post status-publish format-standard has-post-thumbnail category-food-and-drinks category-nightlife tag-bars-that-opened-in-pandemic tag-best-new-bars-central-track tag-dallas-best-new-bars tag-dallas-best-new-bars-2020"><div class="cb-mask cb-img-fw" style="background-color: #cc6b16;"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/">The Best New Dallas Bars Of 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div></div></li> <li class="cb-looper cb-article-2 cb-mm-posts-count-3 cb-style-1 clearfix post-222419 post type-post status-publish format-standard has-post-thumbnail category-culture category-food-and-drinks category-music category-nightlife tag-2020-dallas-closures tag-saddest-closures tag-saddest-dallas-closures tag-this-year-sucked-ass"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/the-saddest-closures-of-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/saddestclosures-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-saddest-closures-of-2020/">The Saddest Dallas Business Closures Of 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-18">December 17, 2020</time></span></div></div></li> <li class="cb-looper cb-article-3 cb-mm-posts-count-3 cb-style-1 clearfix post-222241 post type-post status-publish format-standard has-post-thumbnail category-food-and-drinks category-nightlife tag-christmas-bars tag-dallas-christmas-bars tag-dallas-holiday-bars tag-holiday-pop-up-bars tag-instagrammable-dallas"><div class="cb-mask cb-img-fw" style="background-color: #cc6b16;"><a href="https://www.centraltrack.com/dallas-most-instagrammable-holiday-bars/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/topochico-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/topochico-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/topochico-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/topochico-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/dallas-most-instagrammable-holiday-bars/">Dallas&#8217; Most Instagrammable Holiday Bars.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-15">December 14, 2020</time></span></div></div></li></ul></div><ul class="cb-sub-menu cb-sub-bg">	<li id="menu-item-541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-541"><a href="https://www.centraltrack.com/category/nightlife/party-pics/" data-cb-c="41" class="cb-c-l">Party Pics</a></li>
	<li id="menu-item-543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-543"><a href="https://www.centraltrack.com/category/nightlife/street-style/" data-cb-c="39" class="cb-c-l">Street Style</a></li>
</ul></div></li>
<li id="menu-item-530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-530"><a href="https://www.centraltrack.com/category/film/">TV + Film</a><div class="cb-menu-drop cb-bg cb-mega-menu cb-big-menu clearfix"><div class="cb-sub-mega-three cb-pre-load cb-mega-posts  clearfix"><div class="cb-upper-title"><h2>TV + Film</h2><a href="https://www.centraltrack.com/category/film/" class="cb-see-all">See all</a></div><ul class="cb-sub-posts"> <li class="cb-looper cb-article-1 cb-mm-posts-count-3 cb-style-1 clearfix post-222271 post type-post status-publish format-standard has-post-thumbnail category-film tag-texas-theatre tag-texas-theatre-oak-cliff tag-texas-theatre-renovations tag-texas-theatre-second-screen"><div class="cb-mask cb-img-fw" style="background-color: #85a130;"><a href="https://www.centraltrack.com/the-texas-theatre-is-getting-a-second-screen/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/texastheatre-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/texastheatre-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/texastheatre-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/texastheatre-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-texas-theatre-is-getting-a-second-screen/">The Texas Theatre Is Getting A Second Screen.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-14">December 14, 2020</time></span></div></div></li> <li class="cb-looper cb-article-2 cb-mm-posts-count-3 cb-style-1 clearfix post-221946 post type-post status-publish format-standard has-post-thumbnail category-music category-film tag-dallas-punk-roc-documentary tag-dallas-punk-rock-scene tag-everything-is-a-ok-documentary tag-everything-is-a-ok-punk-documentary tag-justin-powers-everything-is-a-ok tag-justin-powers-fringe-media"><div class="cb-mask cb-img-fw" style="background-color: #00a69c;"><a href="https://www.centraltrack.com/qa-dallas-punk-rock-doc-everything-is-a-ok-director-justin-powers/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/AOK-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/AOK-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/AOK-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/AOK-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/qa-dallas-punk-rock-doc-everything-is-a-ok-director-justin-powers/">[Q&#038;A] Dallas Punk Rock Doc &#8216;Everything Is A-Ok&#8217; Director Justin Powers. </a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-04">December 4, 2020</time></span></div></div></li> <li class="cb-looper cb-article-3 cb-mm-posts-count-3 cb-style-1 clearfix post-221433 post type-post status-publish format-standard has-post-thumbnail category-film tag-dallas-mafia tag-maps tag-sopranos"><div class="cb-mask cb-img-fw" style="background-color: #85a130;"><a href="https://www.centraltrack.com/the-best-20-places-in-dallas-for-sopranos-style-meetups/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/11/sopranos-260x170.jpg" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/11/sopranos-260x170.jpg 260w, https://www.centraltrack.com/wp-content/uploads/2020/11/sopranos-100x65.jpg 100w, https://www.centraltrack.com/wp-content/uploads/2020/11/sopranos-759x500.jpg 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-best-20-places-in-dallas-for-sopranos-style-meetups/">The Best 20 Places In Dallas For Sopranos-Style Meetups.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-11-28">November 23, 2020</time></span></div></div></li></ul></div><ul class="cb-sub-menu cb-sub-bg">	<li id="menu-item-538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-538"><a href="https://www.centraltrack.com/category/film/coming-attractions/" data-cb-c="47" class="cb-c-l">Coming Attractions</a></li>
	<li id="menu-item-539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-539"><a href="https://www.centraltrack.com/category/film/film-reviews/" data-cb-c="48" class="cb-c-l">Film Reviews</a></li>
</ul></div></li>
<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children cb-has-children menu-item-160"><a href="https://www.centraltrack.com/category/culture/">Culture</a><div class="cb-menu-drop cb-bg cb-mega-menu cb-big-menu clearfix"><div class="cb-sub-mega-three cb-pre-load cb-mega-posts  clearfix"><div class="cb-upper-title"><h2>Culture</h2><a href="https://www.centraltrack.com/category/culture/" class="cb-see-all">See all</a></div><ul class="cb-sub-posts"> <li class="cb-looper cb-article-1 cb-mm-posts-count-3 cb-style-1 clearfix post-222670 post type-post status-publish format-standard has-post-thumbnail category-culture tag-asshats-of-dallas tag-central-track-asshats-of-the-year tag-dallas-asshats-of-the-year tag-worst-people-in-dallas tag-worst-things-about-dallas"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-260x170.jpg" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-260x170.jpg 260w, https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-100x65.jpg 100w, https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-759x500.jpg 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/">The Biggest Dallas Asshats Of 2020.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div></div></li> <li class="cb-looper cb-article-2 cb-mm-posts-count-3 cb-style-1 clearfix post-222636 post type-post status-publish format-standard has-post-thumbnail category-culture tag-alien-lawsuit tag-alien-suing-us-government tag-aliens tag-lawsuits tag-niche-drama tag-saturn"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-260x170.jpg" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-260x170.jpg 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-100x65.jpg 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-759x500.jpg 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/">North Texan Claims To Be From Saturn, Sues U.S. Gov&#8217;t.</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-21">December 21, 2020</time></span></div></div></li> <li class="cb-looper cb-article-3 cb-mm-posts-count-3 cb-style-1 clearfix post-222250 post type-post status-publish format-standard has-post-thumbnail category-culture category-music category-song-of-the-day tag-atatiana-jefferson tag-jeff-dazey-central-track"><div class="cb-mask cb-img-fw" style="background-color: #6d30c6;"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/"><img width="260" height="170" src="https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-260x170.png" class="attachment-cb-260-170 size-cb-260-170 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-759x500.png 759w" sizes="(max-width: 260px) 100vw, 260px" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/">Song Of The Day: Jeff Dazey &#8211; &#8220;Song for Atatiana Ft. Greyhounds&#8221;</a></h2><div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-21">December 21, 2020</time></span></div></div></li></ul></div><ul class="cb-sub-menu cb-sub-bg">	<li id="menu-item-204923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204923"><a href="https://www.centraltrack.com/category/culture/things-to-do/" data-cb-c="526" class="cb-c-l">Things To Do</a></li>
	<li id="menu-item-120498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120498"><a href="https://www.centraltrack.com/category/culture/forechecking/" data-cb-c="518" class="cb-c-l">Forechecking</a></li>
	<li id="menu-item-548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-548"><a href="https://www.centraltrack.com/category/culture/asshat-of-the-week/" data-cb-c="49" class="cb-c-l">Asshat of the Week</a></li>
	<li id="menu-item-120499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120499"><a href="https://www.centraltrack.com/category/culture/humor-us/" data-cb-c="527" class="cb-c-l">Humor Us</a></li>
	<li id="menu-item-204922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204922"><a href="https://www.centraltrack.com/category/culture/dtx-selects/" data-cb-c="67567" class="cb-c-l">DTX Selects</a></li>
</ul></div></li>
<li id="menu-item-trending" class="cb-trending"><a href="#" id="cb-trend-menu-item" class="cb-trending-item"><i class="fa fa-bolt"></i> Trending</a><div class="cb-menu-drop cb-mega-menu  cb-bg cb-big-menu"><div id="cb-trending-block" class="cb-mega-trending cb-mega-posts cb-pre-load clearfix"><div class="cb-upper-title"><h2><i class="fa fa-bolt"></i> Trending</h2><span class="cb-see-all"><a href="#" data-cb-r="cb-1" class="cb-selected cb-trending-op">Now</a><a href="#" data-cb-r="cb-2" class="cb-trending-op">Week</a><a href="#" data-cb-r="cb-3" class="cb-trending-op">Month</a></span></div><ul id="cb-trend-data" class="clearfix"> <li class="cb-article-1 clearfix"><div class="cb-mask"><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/">The Biggest Dallas Asshats Of 2020.</a></h2></div><span class="cb-countdown">1</span><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" class="cb-link-overlay"></a></li> <li class="cb-article-2 clearfix"><div class="cb-mask"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/">North Texan Claims To Be From Saturn, Sues U.S. Gov&#8217;t.</a></h2></div><span class="cb-countdown">2</span><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/" class="cb-link-overlay"></a></li> <li class="cb-article-3 clearfix"><div class="cb-mask"><a href="https://www.centraltrack.com/12-dallas-concerts-were-sad-we-missed-in-2020/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/BTS-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div><div class="cb-meta"><h2 class="cb-post-title"><a href="https://www.centraltrack.com/12-dallas-concerts-were-sad-we-missed-in-2020/">12 Dallas Concerts We&#8217;re Sad We Missed In 2020.</a></h2></div><span class="cb-countdown">3</span><a href="https://www.centraltrack.com/12-dallas-concerts-were-sad-we-missed-in-2020/" class="cb-link-overlay"></a></li></ul></div></div></li></ul>		                </div>
	 				</nav>
 				
<div id="cb-content" class="clearfix">
	
	<div class="cb-entire-post cb-first-alp clearfix"data-cb-purl="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" data-cb-pid="222670">

		<div id="cb-featured-image" class="cb-fis cb-fis-fs cb-fis-big cb-fis-block-parallax clearfix"><div class="cb-entry-header hentry cb-meta clearfix"><h1 class="entry-title cb-entry-title entry-title cb-title">The Biggest Dallas Asshats Of 2020.</h1><div class="cb-byline"><span class="cb-author vcard author"><span class="fn"><a href="https://www.centraltrack.com/author/alexgaskin/"><img alt='' src='https://secure.gravatar.com/avatar/10033ce5a7e39632b6c7c4b9821637b8?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/10033ce5a7e39632b6c7c4b9821637b8?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' />Alex Gaskin</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" updated" datetime="2020-12-22">December 22, 2020</time></span></div></div><a href="#" class="cb-vertical-down"><i class="fa fa-angle-down"></i></a></div><div id="cb-parallax-bg"><div id="cb-par-wrap"><img class="cb-image" src="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg" alt=""></div></div>			
		<div class="cb-post-wrap cb-wrap-pad wrap clearfix cb-sidebar-right">

			
					
    <meta itemprop="datePublished" content="2020-12-22T10:30:32-06:00">
    <meta itemprop="dateModified" content="2020-12-22T05:36:21-06:00">
    <meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/">
    <span class="cb-hide" itemscope itemprop="publisher" itemtype="https://schema.org/Organization">
        <meta itemprop="name" content="Central Track">
        <meta itemprop="url" content="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-WebLogoWhite2.png">
        <span class="cb-hide" itemscope itemprop="logo" itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-WebLogoWhite2.png">
        </span>
    </span>
    <span class="cb-hide" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Alex Gaskin"></span>

        
    <meta itemprop="headline" content="The Biggest Dallas Asshats Of 2020.">

      <span class="cb-hide" itemscope itemtype="http://schema.org/ImageObject" itemprop="image" >
        <meta itemprop="url" content="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire.jpg">
        <meta itemprop="width" content="1200">
        <meta itemprop="height" content="944">
    </span>


					<div class="cb-main clearfix">

						
						<article id="post-222670" class="clearfix post-222670 post type-post status-publish format-standard has-post-thumbnail category-culture tag-asshats-of-dallas tag-central-track-asshats-of-the-year tag-dallas-asshats-of-the-year tag-worst-people-in-dallas tag-worst-things-about-dallas">

							
							<section class="cb-entry-content clearfix" itemprop="articleBody">

								<span class="cb-itemprop" itemprop="reviewBody"><h2>After A Year That Packed A Month Of Suffering Into Each Week, Here&#8217;s A List Of 13 Jerks Who Made 2020 Particularly Obnoxious &amp; Terrible For North Texans.</h2>
<p>As it turns out, <a href="https://www.nytimes.com/2020/12/07/climate/climate-change-hottest-november.html">2020 may be the hottest year on record</a>.
<p>That shouldn&#8217;t be too surprising, considering the year started out with <a href="https://www.bbc.com/news/world-australia-50951043">almost all of Australia on fire</a>. On the other hand, however, it&#8217;s a stark reminder that these last 12 miserable months have not just been singularly bad, but also a continuation of older problems, including climate change, that Central Track&#8217;s 2020 coverage hasn&#8217;t directly addressed.
<p>While <a href="https://www.centraltrack.com/40-reasons-dallasites-shouldnt-worry-about-the-vaccine/">the start of vaccine distribution</a> portends an end to the long, difficult stretch of lockdowns and other safety measures meant to protect us against COVID-19, the fact remains: Myriad threats and institutional failures remain unresolved.
<p>Yes, folks: Life <em>can</em> keep getting worse after this blighted year wraps, and temperatures <em>will</em> keep rising as more weather events become existential threats. If that seems excessively apocalyptic, recall that <a href="https://www.npr.org/2020/10/18/925154035/iowa-derecho-this-august-was-most-costly-thunderstorm-event-in-modern-u-s-histor">Iowa endured the landlocked equivalent of a hurricane back in August</a>.
<p>While we here in Dallas didn&#8217;t experience a derecho ourselves, many of this year&#8217;s national calamities had strong ties to our fair city.
<p>Y&#8217;know, per usual.
<p><strong>SEE ALSO:</strong><br />
• <a href="https://www.centraltrack.com/dallas-11-biggest-asshats-of-2016/"><em>DALLAS&#8217; BIGGEST ASSHATS OF 2016.</em></a><br />
• <a href="https://www.centraltrack.com/dallas-asshats-of-2017/"><em>DALLAS&#8217; BIGGEST ASSHATS OF 2017.</em></a><br />
• <a href="https://www.centraltrack.com/dallas-biggest-asshats-of-2018/"><em>DALLAS&#8217; BIGGEST ASSHATS OF 2018.</em></a><br />
• <a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2019/"><em>DALLAS&#8217; BIGGEST ASSHATS OF 2019.</em></a>
<p>This year&#8217;s annual rundown of <a href="https://www.centraltrack.com/category/culture/asshat-of-the-week/">Dallas&#8217; biggest asshats</a> features people who made fighting COVID-19 harder and more confusing; others who pushed the rising far-right and white nationalist anger that&#8217;s become a perpetual threat for terrorist violence; a few who tried in vain to muddy a clear election outcome and hijack the presidency; and still more who undermined efforts to hold police to account for so many instances of unchecked violence.
<p>The Dallas area&#8217;s 2020 was an unusually apt microcosm of the year that the entire country suffered through &#8212; and, as such, this year&#8217;s list of asshats both reflects our connection to broader horrors and reminds us why each day seemed to arrive like a hammer on an unguarded finger.
<p>While this list has historically started with a quick defense and celebration of where we live, 2020 made much of what we love about the Metroplex inaccessible. A lack of support at the local, state and federal levels led to the <a href="https://www.centraltrack.com/a-list-of-permanent-dallas-closures-due-to-covid-19/">closure of many beloved restaurants, bars, shops, and entertainment venues</a>. Safety concerns also necessarily deprived sporting events of their crowds, further separating us from our city&#8217;s flavor. Worse, it seems the legacy of these closures and disruptions will spill over into 2021 and the years to come in many worrying ways. For instance? Among the concerns we face moving forward is the <a href="https://www.msn.com/en-us/news/us/as-eviction-moratorium-ends-advocates-say-thousands-of-north-texans-face-homelessness/ar-BB1bEbyp">potential eviction crisis poised to batter the city at the start of 2021</a>.
<p>If hope feels less accessible this year, perhaps we can turn to shame as an unlikely ally? Admittedly, it&#8217;s optimistic to hope that anyone featured on this list will feel a meaningful kind of shame for their inclusion. Those who are chastened here can likely shrug their feelings aside by tapping into the superpowers so often bestowed to both the powerful and vile: denial, spin and dismissal.
<p>But, hey, guess what? You, dear reader, can plant your feet and hold your ground against them just as easily as they can dig their heels into morally barren earth. You have the right to heap a lifetime of scorn on anyone who contests science and the law during a pandemic for personal or political gain. You don&#8217;t have to take seriously any person or institution willing to overthrow democracy and toss out a fair election. You can refuse to swallow the idea that state-sanctioned violence is necessary. And you never have to &#8220;hear both sides&#8221; when one side is overly &#8212; or, hell, covertly &#8212; racist.
<p>The asshats on this list, much like the less-public ones in your personal life, may insist they have every right to be heard, that their actions are backed by the law or that their views are unfairly censored. As they do so, we suggest turning up your mask-covered nose at them and treating them like the punchlines and ghouls that they are. Shame and disregard them, and give your energy to the people and ideas capable of making the next year better than the nightmare we&#8217;re leaving behind.
<p>With apologies to the many flash-in-the-pan <a href="https://www.centraltrack.com/a-dallas-karen-loses-it-over-a-piece-of-fabric/">Karens</a>, <a href="https://www.centraltrack.com/of-course-viral-gun-nuts-ken-karen-met-at-smu-law/">Kens</a>, <a href="https://www.centraltrack.com/dallas-based-attorney-to-represent-kenosha-shooter/">shadow figures</a> and even <a href="https://www.centraltrack.com/video-we-interviewed-shredded-cheese-wife-guy/">Shredded Cheese Wife Guys</a> we endured over the course of this wild year, the below-listed shit stains are truly on a despicable level all their own.
<h3 style="text-align: center;"><strong>Richard Spencer</strong></h3>
<p>The noted Dallas-sprung white supremacist Richard Spencer hasn&#8217;t become more tolerant or tolerable in 2020, but he <em>has</em> become mercifully less visible <a href="https://www.cnn.com/2020/06/29/tech/white-supremacists-youtube/index.html">thanks to a belated ban from YouTube that occurred over the summer</a>. He&#8217;s also less distinct in the landscape because of an eruption of the provably false COVID talking points, election conspiracies and general far-right wing vitriol that has coated our year with his general type of filth.
<p>Still, Spencer is a mainstay on this asshat list even as the rising contamination of our culture makes his personal supply of bile seem less distinct. He&#8217;s been a central advocate for white nationalism, <a href="https://www.politico.com/news/2020/09/04/white-supremacists-terror-threat-dhs-409236">our country&#8217;s most significant terror threat</a>, and whether he regains a measure of prominence in 2021 or drifts further from relevance, it&#8217;s incumbent upon us all to remember that he and his ilk will be ready and willing to ruin yet another year of ours should they opportunity be afforded them.
<p>In no uncertain words: Spencer remains racist trash, and his face still looks like a mask hastily formed from melted candle wax.
<h3 style="text-align: center;"><strong>Jason Lee Van Dyke</strong></h3>
<p>Although <a href="https://www.centraltrack.com/the-shitbag-denton-lawyer-that-accidentally-doxxed-proud-boys-elder-leaders-central-track/">Denton&#8217;s Jason Lee Van Dyke</a> briefly made his way to the top of the Proud Boys organization a few years back, his incompetence managed to oust him from that group of violent anti-<a href="https://www.dictionary.com/browse/onanist">onanists</a>, which may be <a href="https://www.rawstory.com/2020/11/civil-war-brewing-inside-proud-boys-as-top-leader-says-hes-done-pretending-isnt-a-nazi/">losing its pretense of being &#8220;merely&#8221; far-right</a> as new figures take charge. Still, his bumbling time at the top of the racist food-chain left even his shit-for-brains peers with few kind words to share about him &#8212; a fact that may have hurt his <a href="https://www.vice.com/en/article/wx8xp4/a-proud-boys-lawyer-wanted-to-be-a-nazi-terrorist">attempt to join the right-wing terror outfit The Base</a> in 2020.
<p>In an even slightly better world, Van Dyke would exist as nothing more than a punchline and a cautionary tale for anyone stupid enough to be enticed by right wing ideology. Unfortunately, we live in the world where this slop bucket of a person owns firearms, <a href="https://www.thedailybeast.com/former-proud-boys-lawyer-jason-lee-van-dyke-allegedly-plotted-assassination-of-rival-court-docs-say">allegedly attempted an assassination on a rival</a> and <a href="https://www.thedailybeast.com/proud-boy-lawyer-wants-dollar100m-from-man-who-cost-him-his-job">came close to securing work as a prosecutor for Victoria County</a>.
<p>It&#8217;s scary to think about what could happen if Van Dyke finds a right-wing terror organization willing to accept him; it&#8217;s even more chilling to remember he almost made his way into a public office.
<h3 style="text-align: center;"><strong>Dan Patrick</strong></h3>
<p>What do grandparents <em>really</em> do for us? Love us? Link us to our family histories? Give us the gifts of their wisdom and experience?
<p>Perhaps all of the above, but Texas Lt. Gov. Dan Patrick saw a different kind of value in grandparents and other seniors back in March: He decreed them <a href="https://www.centraltrack.com/asshat-of-the-week-texas-lt-gov-dan-patrick/">noble sacrifices to the coronavirus</a> &#8212; y&#8217;know, for the economy&#8217;s sake!
<p>In an interview with Fox News, <a href="https://www.nbcnews.com/news/us-news/texas-lt-gov-dan-patrick-suggests-he-other-seniors-willing-n1167341">Patrick mused that seniors could &#8212; and would &#8212; put their lives at risk to sustain the health of the economy</a>. Perhaps worse, this analysis arrived at a time when the public was only beginning to learn the importance of social distancing and staying at home.
<p>In a surprising turn, Patrick would actually in early December put forward the idea that everyone who testifies during the upcoming state legislative session be <a href="https://www.ksat.com/news/texas/2020/12/05/dan-patrick-says-people-may-need-to-take-a-coronavirus-test-24-hours-before-testifying-during-the-legislative-session/">tested for the coronavirus 24 hours prior to their arrival in the state Senate</a>.
<p>Is it possible that, after <a href="https://www.centraltrack.com/the-u-s-covid-19-death-count-as-north-texas-cities/">hundreds of thousands of deaths nationwide</a> and over a million globally, Patrick has wised up to the realities of Covid-19? Nah. Make no mistake, this move was made in strictly in the hope that he survives the outbreak. Keep in mind: He&#8217;s still publicly asking that the rest of us keep on going about our daily routines as if more than 300,000 Americans haven&#8217;t been killed as a result of the pandemic.
<p>Sadly, even this position puts him ahead of the many <a href="https://nymag.com/intelligencer/2020/12/trump-administration-staff-with-covid-19-full-updated-list.html">political figures at the national level who can&#8217;t even be counted on to protect themselves</a>.
<h3 style="text-align: center;"><strong>Sidney Powell</strong></h3>
<p>Sidney Powell <a href="https://www.dallasnews.com/news/politics/2020/11/20/5-things-to-know-about-sidney-powell-the-dallas-lawyer-on-trumps-legal-team-alleging-election-fraud/">has a law office in Dallas</a>, but she trekked across the country in the wake of November&#8217;s election to throw her legal weight behind Donald Trump and his election loss. If her name sounds unfamiliar, perhaps you know her better as the lawyer who was supposed to <a href="https://www.politico.com/news/2020/12/03/sidney-powell-trump-election-lawsuit-442472">&#8220;release The Kraken,&#8221;</a> a legal leviathan capable of upending everything we thought we knew about &#8220;contested&#8221; state votes.
<p>In the end, though, that legal maneuver lined up with <a href="https://en.wikipedia.org/wiki/Clash_of_the_Titans_(1981_film)">what its namesake did in<em> Clash of the Titans</em></a> &#8212; which is to say it got its ass kicked.
<p>The post-election frenzied efforts of Republicans to undermine our democracy has swallowed much of the oxygen in the news sphere these last few months, to be sure. And while there&#8217;s plenty to say just about Powell&#8217;s role in advancing this ludicrous legal crusade and the conspiracies girding her arguments, the easiest way to sum up her work up is to point out how <a href="https://www.vox.com/policy-and-politics/2020/11/8/21555022/four-seasons-landscaping-trump-giuliani-philadelphia-press-conference">Rudy Giuliani hosted one press conference at a lawn service company</a> and <a href="https://www.vanityfair.com/news/2020/11/rudy-giuliani-hair-dye-press-conference">then started to melt at another one</a> &#8212; and yet Powell is the one who got fired from the legal team.
<p>Whether Trump decides to give her a special appointment to continue his legal challenges &#8212; <a href="https://www.nytimes.com/2020/12/19/us/politics/trump-sidney-powell-voter-fraud.html">something he apparently wants to keep pursuing</a> even after the electoral college votes have formally been awarded to Joe Biden &#8212; it&#8217;s abundantly clear now that Powell&#8217;s Kraken, like so many other monsters on film, will need to forcibly push its way into a painful and needless sequel if there is to be one at all.
<h3 style="text-align: center;"><strong>Thomas Rousseau</strong></h3>
<p>Patriot Front founder Thomas Rousseau <a href="https://www.dailykos.com/stories/2020/8/4/1966538/-Founder-of-fascist-Patriot-Front-group-arrested-in-Texas-for-plastering-stickers-at-courthouse">was arrested in Parker County for pasting his group&#8217;s vile and racist messaging on county property</a> over the summer. Unfortunately, 2020 won&#8217;t let us have anything truly nice, and this fart in the wind was only charged with a misdemeanor for his spreading of hate.
<p>Much like his fellow area-sprung hatemonger Richard Spencer, the Fort Worth-raised Rousseau has given repellent white ghouls encouragement and space to come together and luxuriate in their shared fears and hatreds. And he just keeps on at it, too: Rousseau created Patriot Front after his previous organization, Vanguard America, was linked to the murder of Heather Heyer by group member James Fields at the 2017 Unite The Right rally in Charlottesville, Virginia.
<p>Since its formation in the immediate wake of that tragedy, Patriot Front has expanded beyond Texas, and now pushes propaganda throughout the country &#8212; including Pittsburgh, <a href="https://forward.com/news/458887/2-years-after-the-synagogue-shooting-pittsburgh-has-become-a-hub-for-white/">a city that Rousseau&#8217;s and other groups seem to enjoy terrorizing because it was the site of the Tree of Life Synagogue massacre</a>. Patriot Front members appear more than eager to engage in more extreme acts of terrorism, too: <a href="https://www.vice.com/en/article/7k98e4/inside-how-a-terror-group-recruited-budding-neo-nazis">Some of its crew are now drifting toward The Base</a>, the neo-Nazi terror group that rejected the aforementioned Jason Lee Van Dyke.
<p>Rousseau has worked hard to promote hate for his entire adult life: He&#8217;s a seemingly tireless propagandist and white nationalist who continues to reach out to other glass-eyed husks of vanilla skin that are amenable to his racist rhetoric.
<p>If nothing else, counting him among the worst byproducts of Dallas-Fort Worth is an unpleasant reminder that we have to do more than just hope that racism will fade as past generations are whittled down by time.
<h3 style="text-align: center;"><strong>Kenneth Copeland</strong></h3>
<p>With an estimated net worth of some $300 million, Kenneth Copeland is <a href="https://www.ibtimes.com/kenneth-copeland-net-worth-evangelist-richest-pastor-world-2951331">believed to be the richest pastor in the world</a> &#8212; a dubious honor, indeed, considering how his stated faith tells us that <a href="https://biblehub.com/matthew/19-24.htm">it&#8217;s &#8220;easier for a camel to pass through the eye of a needle than for a rich man to enter the kingdom of God.&#8221;</a>
<p>Alas, it must be conceded: The Fort Worth pastor has done quite well for himself &#8212; materially speaking, anyway &#8212; when it comes to promoting Christianity. But even he would be hard-pressed to acquit himself well it comes to the issues of COVID-19, which he claimed repeatedly throughout 2020 that he could personally destroy &#8212; in one case by suggesting that him simply breathing on it would eradicate it from our earthly realm.
<p>During an April sermon in an empty church, Copeland – who had already boasted he could heal COVID-infected followers by having them place their hands on their screens while watching him proselytize – claimed he could <a href="https://www.centraltrack.com/fort-worth-televangelist-blows-wind-of-god-on-covid-19/">&#8220;blow the &#8216;Wind of God&#8217; on&#8221; the virus and remove its pernicious hold upon our country</a>.
<p>The Lord may work in mysterious ways, but here&#8217;s one mystery we can solve right now:  Kenneth Copeland&#8217;s breath did <em>not</em> stop the virus, which <a href="https://www.centraltrack.com/covid-briefs-the-first-covid-19-vaccinations-have-officially-been-administered/">remains a serious public health risk</a> some eight months after his promise that it would.
<p>While Copeland has more recently drawn scrutiny for his <a href="https://www.msn.com/en-us/news/politics/kenneth-copeland-laughing-at-media-declaring-biden-s-win-watched-8-million-times/ar-BB1aPJsA">bizarre performative cackle in response to the initial news of Joe Biden&#8217;s election victory</a>, perhaps he was simply using the &#8220;Chuckle of God&#8221; to blow the election results away?
<p>Who cares? This clown deserves <a href="https://www.youtube.com/watch?v=0JPRvxTjfOk">every parody he faces</a>.
<h3 style="text-align: center;"><strong>The Back The Blue Caravan</strong></h3>
<p>If you&#8217;ve seen <a href="https://en.wikipedia.org/wiki/Society_(film)">the 1989 body horror/comedy film<em> Society</em></a>, you don&#8217;t need to be reminded of its grotesque third-act reveal. For those who <em>haven&#8217;t</em> seen it, the minimally revolting gist is that the &#8220;high society&#8221; movers and shakers in the film are physiologically malleable enough to shift their forms and literally merge with on another to form an elaborate, quivering mass.
<p>That&#8217;s not a pleasant image, no &#8212; but it&#8217;s going to be useful as we <a href="https://www.centraltrack.com/asshats-of-the-week-yes-that-back-the-blue-caravan/">talk about August&#8217;s Back the Blue caravan</a>, which manipulated its way onto the property of Friendship-West Baptist Church under false pretenses back in August.
<p>After members of the Texas Ram Club and the North Texas Jeep Club asked for and received the OK of an Oak Cliff church &#8212; one that&#8217;s been vocally supportive of the Black Lives Matter movement &#8212; to use their parking lot as a rest stop during a drive ostensibly tied to automotive brand fandom, the group arrived on the scene brandishing pro-Trump and Confederate flags along with pro-police imagery.
<p>In the wake of the ensuing controversy that naturally followed at the behest of offended church leaders, <a href="https://www.msn.com/en-us/news/us/back-the-blue-cruise-wasnt-supposed-to-be-political-thats-not-how-it-turned-out/ar-BB17ubRn">co-organizer Nathan Abrams claimed his rally was meant to be an &#8220;apolitical&#8221; message of support for the police</a> and dismissed the uproar as a matter of miscommunication. Only, well, what we <em>all saw</em> what was easy enough to recognize. Like the monsters in <em>Society</em>, the members of these respective car groups merged to create a cretinous, mean-spirited bulk of assholes &#8212; one that shamefully chose an unwitting church, of all places, as its target.
<p>The lesson here: Denials of reality don&#8217;t carry weight when your hideousness has already been exposed to the public.
<h3 style="text-align: center;"><strong>Shelley Luther</strong></h3>
<p>Texas has been battered hard by the ongoing COVID-19 crisis, and it has consistently maintained its position near or at the top of the ongoing list of positive cases and deaths by state. But while our government&#8217;s preventive measures in the face of the pandemic have been criticized by some for being too limited, the annoying truth is that our state&#8217;s comparatively tepid impositions were more than some of our fellow Texans could bear.
<p>But while <a href="https://www.star-telegram.com/news/coronavirus/article245394750.html">many pushed back against Texas&#8217; efforts to stop the spread of coronavirus</a>, few were as savvy in their opposition as Shelley Luther was. In April, she essentially <em>dared</em> the state to punish her by broadcasting her commitment to keeping her salon open despite regulations demanding she close up shop. Immediately upon her challenge, several top Texas Republicans &#8212; including Texas Gov. Greg Abbott, who we&#8217;ll get to in a minute &#8212; succumbed to their base&#8217;s support of Luther&#8217;s actions and backed down from their stances, prioritizing votes over potentially lost lives.
<p>The seven-day prison sentence Luther was issued for defying lockdown orders quickly ended after two short days &#8212; and, after <a href="https://www.foxnews.com/media/greg-abbott-coronavirus-restrictions-texas-masks">going on Fox News to applaud her direct violation of his orders</a>, Abbott further cucked by <a href="https://abcnews.go.com/US/dallas-salon-owner-jailed-violating-stay-home-order/story?id=70555646">retroactively eliminating jail sentences for other offenders</a> of his coronavirus-related directives.
<p>A little context: At the time all this was going down, Dallas County had the second-highest number of cases in the state; 123 people had already died, and while some of those people we lost maybe also hated the lockdowns, we can&#8217;t really ask them now.
<p>In the months that followed her initial name-making stunt, Luther&#8217;s profile &#8212; kinda like the number of people killed by COVID-19! &#8212; only continued to rise. Later in the summer, she <a href="https://www.centraltrack.com/shelley-luther-is-running-for-office-we-guess/">announced her plan to run for the Texas State Senate District 30 seat</a> and, because state politics apparently did away with irony along with decency, tis woman who became famous for breaking the law announced her candidacy at a pro-police Back the Blue rally.
<p>In the end, <a href="https://crushbandusa.com/crush">the former cover band singer</a>&#8216;s political campaign proved unsuccessful, but Luther can still take pride in how far she&#8217;s come since she defied orders to protect the public from a virus that, as of this writing, has <a href="https://covid.cdc.gov/covid-data-tracker/#cases_totaldeaths">gone on to kill more than 25,000 Texans</a>.
<h3 style="text-align: center;"><strong>Chad Wolf</strong></h3>
<p>Like <a href="https://www.gq.com/story/hope-hicks-mystifying-triumph-donald-trump">fellow local product Hope Hicks</a>, who worked under both Donald Trump and Jared Kushner, Chad Wolf rode the ethical sluice from Southern Methodist University to the Trump White House.
<p>It may seem fair to assume that the path from an expensive private university to a morally dubious position like Acting Secretary of Department of Homeland Security is smooth and swift, but no: The Plano-raised Wolf had a rougher-than-expected trajectory, as his <a href="https://www.cnn.com/2020/09/14/politics/judge-chad-wolf/index.html">appointment was determined to be &#8220;likely unlawful&#8221;</a> due to the fact that Kevin McAleenan, who made Wolf&#8217;s appointment, was himself not validly appointed when he made it.
<p>Is it embarrassing for a nation to have top government positions staffed by people who are basically at the core of a nesting doll of improper appointments? Yes! But at least someone with a tenuous grip on his position is less likely to draw unwanted attention with bold and broadly harmful actions, right? Unfortunately, no.
<p>With all the apparent swagger of a<a href="https://time.com/3720498/ncaa-smu-death-penalty/"> college football team that even the NCAA deemed unethical</a>, Wolf involved himself in one of the more nakedly cruel actions taken by the Trump White House. In June, after the Supreme Court stopped one of our president&#8217;s attacks on the Deferred Action for Childhood Arrivals, Trump went right back to attacking it, seeking to suspend it until all legal challenges had been cleared. In response, the dutiful Wolf then exercised his dubious authority to force the suspension, <a href="https://immigrationforum.org/article/fact-sheet-on-deferred-action-for-childhood-arrivals-daca/">leaving hundreds of thousands of people</a> without the protection they&#8217;d depended on against threats of deportation.
<p>Eventually, the deep sketchiness surrounding Wolf&#8217;s rise actually worked in the favor of those who depended on DACA: In November, a federal judge determined that, because Wolf&#8217;s appointment was not lawful, he <a href="https://www.nbcnews.com/politics/immigration/federal-judge-rules-acting-dhs-head-chad-wolf-unlawfully-appointed-n1247848">wasn&#8217;t really allowed to suspend the act as he had</a>.
<p>Now, with Trump on his way out, Wolf&#8217;s not-really-his-job at DHS is almost certainly near its end. His time at the top was brief, unfairly given and spent maliciously. While that actually doesn&#8217;t sound overly remarkable for someone in the Trump Administration &#8212; <a href="https://www.npr.org/2020/03/09/813577462/how-trump-has-filled-high-level-jobs-without-senate-confirmation">plenty of people skated into powerful positions throughout this presidency without following the proper channels</a> &#8212; at least we got to watch Wolf suffer the indignity of being an SMU grad who actually gets called out for not really deserving the opportunity he was handed.
<h3 style="text-align: center;"><strong>Eric Johnson</strong></h3>
<p>Dallas was not gentle with its leaders this year. The COVID-19 pandemic and <a href="https://www.centraltrack.com/a-detailed-look-at-some-reforms-proposed-for-dpd/">the public calls for police reform</a> alike greatly challenged our civic institutions, insisting on significant changes that would have to be made with haste.
<p>But by the end of April &#8212; even before the protests crying for changes within DPD <a href="https://www.centraltrack.com/a-brief-look-at-dallas-protests-from-this-weekend/">really kicked off</a> &#8212; we had to wonder aloud <a href="https://www.centraltrack.com/wheres-the-dallas-mayor-can-you-find-eric-johnson/">where Dallas Mayor Eric Johnson even was</a> while the coronavirus started to spread and residents began falling ill in alarming numbers. Sure, Dallas County Judge Clay Jenkins was <a href="https://www.centraltrack.com/inside-dallas-county-judge-clay-jenkins-pandemic-life/">there to step in and implement countywide safety measures</a>, but reassurance, guidance and encouragement from the holder of the city&#8217;s most prominent office was decidedly absent.
<p>By the way: Johnson&#8217;s apparent disappearance weirdly occurred right around the same time that he <a href="https://www.dmagazine.com/frontburner/2020/04/eric-johnson-uses-pandemic-to-go-strong-mayor-on-council/">tried making a case to secure more power for his seat</a>. One measure he implemented during this push was the creation of two ad hoc committees meant to oversee virus-related developments &#8212; a move that would eventually cause an awkward doubling of meetings and work, and would later <a href="https://www.centraltrack.com/city-council-session-shows-lack-of-leadership-in-dallas/">lead to bitter confusion</a> and <a href="https://www.dmagazine.com/frontburner/2020/05/mayor-eric-johnson-starts-memorial-day-weekend-with-a-fight/">public spats between Johnson and City Manager T.C Broadnax</a>.
<p>Later, in the wake of George Floyd&#8217;s death in May, Dallasites joined the citizens of major cities throughout the country in <a href="https://www.centraltrack.com/today-is-day-100-of-police-brutality-protests-in-dallas-texas/">taking to the streets and demanding civic reforms</a>, including the shrinking of increasingly bloated police budgets in exchange for supporting other public services capable of actually helping local communities. Here, it appeared, was a second major event begging for strong local leadership. But as protesters demanded justice, and DPD responded by <a href="https://www.centraltrack.com/exclusive-heres-dpds-unreleased-protest-after-action-report/">deploying an estimated 652 projectiles on civilians</a>, Johnson diminished those efforts by <a href="https://www.centraltrack.com/dpd-releases-protester-arrest-info-to-media/">claiming they were being driven by outsiders</a>, and not actual Dallas residents &#8212; a form of deflection leaders often use to <a href="https://www.cnn.com/2020/06/04/us/outside-agitator-label-history-trnd/index.html#:~:text=The narrative of the 'outside agitator' has long,by Southern white people as an outside agitator.">challenge</a> messages and movements they find discomfiting.
<p>He would then go on to <a href="https://dfw.cbslocal.com/2020/09/03/dallas-council-members-reject-proposed-salary-cuts-city-hall-reduced-funding-police/">try and counter a city push to reduce police overtime budgets by pushing to instead defund bureaucratic positions</a> &#8212; a cynical, almost comically spiteful opposition to an already weak reform.
<p>Throughout the year, Johnson&#8217;s been selectively visible, fought with colleagues and made efforts to undermine progressive changes to policing while <a href="https://www.nbcdfw.com/news/local/nbc-5-exclusive-dallas-police-chief-offended-and-exhausted-by-mayors-comments/2485430/">blaming the outgoing police chief for a rise in homicides</a> &#8212; a continued rise that <a href="https://www.centraltrack.com/5-things-eric-johnson-must-address-as-dallas-new-mayor/">we at Central Track called on him to confront himself when elected last year</a> after having downplayed the issue during his campaign.
<p>Overall, Johnson has spent 2020 out of sight, out of step and generally happier to <a href="https://www.centraltrack.com/the-books-kept-on-dallas-mayor-eric-johnsons-shelves/">chat with national media figures in an effort at projecting an aura of leadership</a> than to exercising any such values for our benefit.
<p>Dallas didn&#8217;t have the leader it needed this year, but it had one that certainly felt appropriate for 2020.
<h3 style="text-align: center;"><strong>U. Renee Hall</strong></h3>
<p>Now-former Dallas Police Department Chief Renee Hall&#8217;s tenure at the top of our police force couldn&#8217;t withstand the frenzy that was 2020 &#8212; so much so that <a href="https://www.centraltrack.com/chief-renee-hall-is-resiging-from-dpd/">she announced her resignation in September</a>, giving in to months of <a href="https://www.centraltrack.com/dpd-chief-renee-hall-needs-to-resign/">public calls for her to do so</a>.
<p>Currently, the city is <a href="https://www.centraltrack.com/meet-the-seven-finalists-for-dallas-next-police-chief/">searching for her replacement</a> &#8212; and whoever takes on the job will have plenty of work to do in terms of righting a ship that&#8217;s <a href="https://www.centraltrack.com/dallas-police-department-many-issues-dpd-is-so-fucked/">long been sinking</a>.
<p>Hall didn&#8217;t make much progress at all in fixing DPD&#8217;s many glaring issues while serving as its top cop from 2017 to 2020. During her time as chief, violent crime in Dallas has risen and <a href="https://www.centraltrack.com/dallas-annual-homicide-count-for-every-year-since-1930/">homicides have likewise increased</a>. Did the mayor&#8217;s repeated blaming of Hall for our city&#8217;s ills this year feel like a convenient way for him to avoid his own responsibility for these issues? Sure, but that&#8217;s still far from a glowing endorsement of Hall&#8217;s tenure.
<p>Truth is, even if crimes <em>had</em> been on the decline during her watch, Hall&#8217;s actions in the wake of the DPD&#8217;s treatment of protesters this summer were still inexcusable. Over the course of multiple City Hall meetings held to discuss what transpired during the early days of this summer&#8217;s protests, Hall &#8212; despite <a href="https://www.dallasnews.com/news/2020/05/30/why-dallas-police-chief-renee-hall-made-the-call-to-use-tear-gas-at-george-floyd-protests/">having previously and publicly authorized them to do so</a> &#8212; repeatedly denied that her officers had used tear gas on the protesters that they&#8217;d <a href="https://www.centraltrack.com/a-few-words-on-the-ambush-at-large-marge/">kettled and detained on the Margaret Hunt Hill Bridge on June 1</a>. But an <a href="https://www.centraltrack.com/exclusive-heres-dpds-unreleased-protest-after-action-report/">internal city document obtained and exclusively published by Central Track</a> later showed that DPD had indeed fired tear gas upon those civilians &#8212; and proved that Hall either knowingly or, with gross negligence, lied about that fact.
<p>Under her watch, Dallas cops also <a href="https://www.centraltrack.com/video-shows-cops-laughing-after-shooting-dallas-protester/">laughed while firing &#8220;less-lethal&#8221; weapons upon protesters</a> and were deemed irresponsible enough with such ammo <a href="https://www.centraltrack.com/attorneys-agree-to-extend-dpd-ban-on-less-lethal-weapons-through-nov-15/">that a court order successful, if only temporarily, banned the department&#8217;s use of those weapons</a>.
<p>Even <a href="https://www.centraltrack.com/keeping-up-with-dpds-pledges-to-change/">with reforms promised</a> and enacted, Hall&#8217;s failures were too deep and too many to be excused &#8212; and <a href="https://www.centraltrack.com/our-cliffsnotes-on-dpds-final-protest-after-action-report/">any trust she&#8217;d earned among local politicians was completely lost</a> in the end.
<p>Clearly, Dallas needed a better police chief in 2020. Now, as her eventual replacement <a href="https://www.centraltrack.com/quick-thoughts-on-dallas-police-chief-candidate-forum/">is being vetted, interviewed and considered</a>, we can only hope that someone actually up to the task &#8212; and willing to accept community input in ways Hall never was &#8212; gets the gig.
<h3 style="text-align: center;"><strong>Ken Paxton</strong></h3>
<p>In September, <a href="https://www.texastribune.org/2020/10/03/texas-ken-paxton-bribery-investigation/">senior officials in Texas Attorney General Ken Paxton&#8217;s own office called for a federal investigation into their boss&#8217; actions</a>, levying against him charges of abuse of power, improper influence and bribery. Big shocker here: Those behind those calls for an investigation have since been fired, put on leave or resigned, and <a href="https://apnews.com/article/business-ken-paxton-lawsuits-crime-austin-37b02b4f9ab93ed6d39c911f70e70210">three of them are now suing the state for retaliation and wrongful termination of their employment</a>.
<p>For a moment there, these accusations seemed embarrassing and potentially damning enough to truly threaten Paxton, who has spent almost all his time in office pushing off <a href="https://www.texastribune.org/2019/06/19/ken-paxton-criminal-case-timeline-texas-attorney-general-fraud/">earlier felony fraud accusations </a>. His prospects looked grim. Who could he appeal to for help when <a href="https://www.foxnews.com/politics/texas-gov-greg-abbott-says-new-criminal-allegations-against-ag-ken-paxton-raise-serious-concerns">even the governor and lieutenant governor were withholding their support</a>?
<p>In a normal year, he might&#8217;ve been done at this point &#8212; just another sanctimonious demagogue whose alleged volume of crimes pointed to his surefire undoing. But when another powerful and scandal-plagued conservative found himself facing the loss of his office, Paxton found a way to change the narrative. Backed by the support of sympathetic states, a worrying number of Republican officials nationwide and eventually Donald Trump himself, <a href="https://slate.com/news-and-politics/2020/12/ken-paxton-texas-lawsuit-scotus-election-pardon.html">Paxton attempted to sue four battleground states</a> in the hopes of overturning voter outcomes and reversing the winner of the presidential election.
<p>While Paxton&#8217;s legal skills are formidable enough to make felony charges against him drag on for half a decade and counting, his rally to defend Trump&#8217;s presidency was fortunately and quickly squashed flat by the Supreme Court roughly a week after it was attempted.
<p>It should be said: This play was not the first example of Paxton&#8217;s shameless, showy sycophancy. When George W. Bush was in the White House, <a href="https://www.texasmonthly.com/politics/ken-paxton-texas-attorney-general-first-two-years/">then-legislator Paxton pushed for our &#8220;Welcome to Texas&#8221; signs to acknowledge the president&#8217;s connection to the state</a>. What sets this latest demonstration of pitiful toadying apart, however, is that it comes at a time when Paxton&#8217;s personal legal troubles have been amplified.
<p>Across the board, <a href="https://www.cnn.com/2020/12/16/politics/donald-trump-pardons-lame-duck/index.html">the prospect of a pardon from the outgoing president</a> has sweetened the air enough to encourage various allies and associates to attempt a show of impotent fealty before a soon-to-be-powerless Trump &#8212; Paxton among them. Even so, <a href="https://www.msn.com/en-us/news/politics/ken-paxton-insists-he-is-not-seeking-trump-pardon-with-election-lawsuit/ar-BB1bPXCu">Paxton has publicly claimed that his failed lawsuit was <em>not</em> about securing a pardon</a>.
<p>But should we believe him? C&#8217;mon. Remember the other charges he&#8217;s still facing?
<p>Once a fraud, always a fraud.
<h3 style="text-align: center;"><strong>Greg Abbott</strong></h3>
<p>Texas Gov. Greg Abbott, not unlike Dallas Mayor Eric Johnson, had to perform his duties in a terrifying new reality this year &#8212; one that seemed to upend every norm to which we once adhered.
<p>But, whereas Johnson was relatively new to his role, Abbott has had years to learn the nuanced and broad maneuvers he could make in his office &#8212; and time aplenty to build a network of allies, experts and advisers to help steer him through catastrophe.
<p>Yet, even with this experience and backing behind him, Abbott still let Texas suffer an almost incomprehensibly brutal and immiserating year.
<p>The governor was slow to implement a mask mandate, only putting one in place at the start of July. Even earlier in the pandemic, back in April &#8212; weeks after declaring a state of emergency based on the onset of coronavirus cases &#8212; Abbott actually <em>did</em> implement a series of lockdown rules in line with those other states, only to then too quickly ease them before the virus was truly under control. At the same time, he somehow also <a href="https://www.centraltrack.com/quarantine-qa-dallas-bar-owner-brandon-hays/">managed to leave the service industry out to dry</a>.
<p>It&#8217;s shameful, really.
<p>Despite his theoretical authority and influence over like-minded constituents, the few rules he put in place were slammed by the left, vocally rebuked from the right by people like Shelley Luther and even ultimately <a href="https://www.cbsnews.com/news/texas-coronavirus-face-masks-sheriffs-refuse-enforce-governor-abbott-order/">undermined by Texas sheriffs</a>. And, in a particularly embarrassing turn, the governor cowardly crumbled in the face of his own rules, backing down from imposing jail sentences against offenders thanks to Luther&#8217;s performative protests.
<p>His loose lockdown regulations and mask mandates &#8212; as implemented or, better put, as not &#8212; failed to protect the tens of thousands of Texans who have died from COVID-19 and the more than 1.5 million residents who have been sickened by it.
<p>If there ever was a pretense that Abbott&#8217;s political philosophy and approach to governing were intended to help anyone beyond the most privileged of Texans, we can now confidently cast those aside like the many disposable face masks we&#8217;ve relied on to make it through the year.
<p>To wit: After everything that happened this year, after all of his claims that the pandemic was under control and not to be feared, <a href="https://twitter.com/PatrickSvitek/status/1341111962458066948">Abbott is now set to be among the first in the state to be administered a vaccine</a>.
<p>What an empty suit he is.
<p>While COVID-19 has obviously ravaged our the entire nation in 2020, the objective truth is that few states have struggled in its face as consistently poorly as Texas has with Abbott at the helm.
<p>In a regular year, we might expect to use this space to shame our governor for bureaucratic nightmares or legislative grandstanding. This year, we include him for the blood on his hands and the irreparable economic havoc that his cowardly governing wreaked.
<p>We hope he&#8217;s pleased with the job he did in 2020. Because literally no one else is.
<div id="bsa-block-728--90" class="bsaProContainerNew bsaProContainer-6 bsa-block-728--90 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=6&bsa_pro_id=1175&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bfi_thumb/1590130449-shit-happens-banner-ad-v2_1456-opvrvd2e4wye5v7usw1soxzd2lyodq4t6wgsjxf2x0.png&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "6";
					var object = $(".bsaProContainer-" + sid);
					var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "728";
					var parentHeight = "90";
					var objectWidth = object.parent().outerWidth();
//					var objectWidth = object.width();
					if ( objectWidth <= parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							imageThumb.height(parentHeight * scale);
//							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
//							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						imageThumb.height(parentHeight);
//						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-6 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-6');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						</span>																
							</section> <!-- end article section -->
							
							<footer class="cb-article-footer">
								<div class="cb-social-sharing cb-color-buttons cb-post-footer-block cb-on-color clearfix"><div class="cb-color-sharing-buttons"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" target="_blank" class="cb-social-fb cb-tip-bot" data-cb-tip="Share"><i class="fa fa-facebook" aria-hidden="true"></i></a><a href="https://twitter.com/share?url=https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" target="_blank" class="cb-social-tw cb-tip-bot" data-cb-tip="Tweet"><i class="fa fa-twitter" aria-hidden="true"></i></a><a href="//www.pinterest.com/pin/create/button/?url=https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" target="_blank" class="cb-social-pin cb-tip-bot" data-cb-tip="Pin it"><i class="fa fa-pinterest" aria-hidden="true"></i></a><a href="https://plus.google.com/share?url=https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/" target="_blank" class="cb-social-go cb-tip-bot" data-cb-tip="Share"><i class="fa fa-google-plus" aria-hidden="true"></i></a><a href="/cdn-cgi/l/email-protection#704f121f14094d18040400034a5f5f0707075e13151e0402111c040211131b5e131f1d5f0418155d121917171503045d14111c1c11035d110303181104035d1f165d424042405f" class="cb-social-em cb-tip-bot" data-cb-tip="Email"><i class="fa fa-envelope" aria-hidden="true"></i></a></div></div><div class="cb-post-large cb-post-footer-block clearfix"><center></center></div><div id="cb-next-previous-posts" class="cb-next-previous cb-post-block-bg cb-post-footer-block cb-font-header clearfix"><div class="cb-previous-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-left"></i></div><span class="cb-read-previous-title cb-read-title"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/">Previous Article</a></span><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/" class="cb-previous-title cb-title">The Best New Dallas Bars Of 2020.</a></div><div class="cb-next-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-right"></i></div><span class="cb-read-next-title cb-read-title"><a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/">Next Article</a></span><a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/" class="cb-next-title cb-title">The Cocktease: The Milk Punch at Krio.</a></div></div><div id="cb-author-box" class="cb-post-footer-block cb-post-block-bg clearfix"><div class="cb-mask"><a href="https://www.centraltrack.com/author/alexgaskin/"><img alt='' src='https://secure.gravatar.com/avatar/10033ce5a7e39632b6c7c4b9821637b8?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/10033ce5a7e39632b6c7c4b9821637b8?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></a></div><div class="cb-meta"><div class="cb-title cb-font-header"><a href="https://www.centraltrack.com/author/alexgaskin/"><span>Alex Gaskin</span></a></div><div class="cb-author-position cb-font-header">Contributor</div><p class="cb-author-bio">Alex Gaskin is a writer and standup comic in Dallas, TX. His writing has appeared in Central Track, Irish Film Critic, and Dallas Entertainment Journal. He's performed standup at comedy clubs, bars, a convenience store (twice), and comedy festivals. He interviews other Dallas comics for Central Track's Humor Us series. Find his Twitter self at @alex_j_gaskin.</p><div class="cb-author-page-contact"> <a href="//www.twitter.com/alex_j_gaskin" target="_blank" class="cb-contact-icon cb-tip-bot" data-cb-tip="Twitter"><i class="fa fa-twitter"></i></a></div></div></div><div id="cb-related-posts-block" class="cb-post-footer-block cb-arrows-tr cb-module-block clearfix"><h3 class="cb-title cb-title-header">Related Posts</h3><div id="cb-related-posts" class="cb-slider-2 cb-slider cb-meta-below"><ul class="slides clearfix">                <li class="cb-style-1 clearfix cb-no-1 post-222636 post type-post status-publish format-standard has-post-thumbnail category-culture tag-alien-lawsuit tag-alien-suing-us-government tag-aliens tag-lawsuits tag-niche-drama tag-saturn">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/saturn-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/north-texan-claims-to-be-from-saturn-sues-u-s-govt/">North Texan Claims To Be From Saturn, Sues U.S. Gov&#8217;t.</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/petefreedman/">Pete Freedman</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-21">December 21, 2020</time></span></div>                    </div>
                </li>
                <li class="cb-style-1 clearfix cb-no-2 post-222250 post type-post status-publish format-standard has-post-thumbnail category-culture category-music category-song-of-the-day tag-atatiana-jefferson tag-jeff-dazey-central-track">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/jeffdazey-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/song-of-the-day-jeff-dazey-song-for-atatiana-ft-greyhounds/">Song Of The Day: Jeff Dazey &#8211; &#8220;Song for Atatiana Ft. Greyhounds&#8221;</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/jessipereira/">Jessi Pereira</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-21">December 21, 2020</time></span></div>                    </div>
                </li>
                <li class="cb-style-1 clearfix cb-no-1 post-222572 post type-post status-publish format-standard has-post-thumbnail category-culture tag-chief-of-police-central-track tag-dallas-chief-of-police-nominees tag-dallas-police-chief tag-dpd-chief-search tag-would-you-rather-chief">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/would-you-rather-whos-your-pick-for-dpds-next-chief/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/CHIEF-1-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/would-you-rather-whos-your-pick-for-dpds-next-chief/">Would You Rather: Who&#8217;s Your Pick For DPD&#8217;s Next Chief?</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/jessipereira/">Jessi Pereira</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-18">December 18, 2020</time></span></div>                    </div>
                </li>
                <li class="cb-style-1 clearfix cb-no-2 post-222511 post type-post status-publish format-standard has-post-thumbnail category-culture tag-covid-vaccine-arrives-north-texas tag-covid-vaccine-in-north-texas tag-covid-vaccine-meme tag-dallas-covid-vaccine tag-dallas-dont-about-worry-about-vaccine">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/40-reasons-dallasites-shouldnt-worry-about-the-vaccine/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/needle-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/40-reasons-dallasites-shouldnt-worry-about-the-vaccine/">40 Reasons Dallasites Shouldn&#8217;t Worry About The Vaccine.</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/petefreedman/">Pete Freedman</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-18">December 18, 2020</time></span></div>                    </div>
                </li>
                <li class="cb-style-1 clearfix cb-no-1 post-222495 post type-post status-publish format-standard has-post-thumbnail category-culture tag-covid-briefs tag-dallas-covid-vaccine tag-perla-sanchez-nurse tag-teresa-mata-dallas tag-teresa-mata-methodist">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/covid-briefs-the-first-covid-19-vaccinations-have-officially-been-administered/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/03/COVID19-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/covid-briefs-the-first-covid-19-vaccinations-have-officially-been-administered/">COVID Briefs: Dallas&#8217; First Vaccinations Get Administered.</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/jessipereira/">Jessi Pereira</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-18">December 18, 2020</time></span></div>                    </div>
                </li>
                <li class="cb-style-1 clearfix cb-no-2 post-222464 post type-post status-publish format-standard has-post-thumbnail category-culture tag-city-of-dallas tag-dallas-police-department tag-dpd-chief tag-niche-drama">
                    <div class="cb-mask"><a href="https://www.centraltrack.com/quick-thoughts-on-dallas-police-chief-candidate-forum/"><img width="360" height="240" src="https://www.centraltrack.com/wp-content/uploads/2020/12/chiefcover-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></a></div>
                    <div class="cb-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/quick-thoughts-on-dallas-police-chief-candidate-forum/">Quick Thoughts On Dallas&#8217; Police Chief Candidate Forum.</a></h4>
                        <div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.centraltrack.com/author/petefreedman/">Pete Freedman</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-12-17">December 17, 2020</time></span></div>                    </div>
                </li>
</ul></div></div>							</footer> <!-- end article footer -->

						</article> <!-- end article -->						

					</div> <!-- end .cb-main -->

			
			
			
<aside class="cb-sidebar clearfix"><div id="search-5" class="cb-sidebar-widget widget_search"><form method="get" class="cb-search" action="https://www.centraltrack.com/">

    <input type="text" class="cb-search-field cb-font-header" placeholder="Search.." value="" name="s" title="" autocomplete="off">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>
    
</form></div><div id="bsa-block-300--250" class="bsaProContainerNew bsaProContainer-3 bsa-block-300--250 bsa-pro-col-12" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=3&bsa_pro_id=1176&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bsa-pro-upload/1592521962-BentonWilliams_600x500.jpg&#39;)"></div></a></div></div></div></div><div class="bsaProItem " data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=3&bsa_pro_id=1173&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bsa-pro-upload/1590129977-shit-happens-side-bar-ad-v4_600.png&#39;)"></div></a></div></div></div></div></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
			(function($){
				function bsaProResize() {
					var sid = "3";
					var object = $(".bsaProContainer-" + sid);
					var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "250";
					var objectWidth = object.parent().outerWidth();
//					var objectWidth = object.width();
					if ( objectWidth <= parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							imageThumb.height(parentHeight * scale);
//							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
//							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						imageThumb.height(parentHeight);
//						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-3 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-3');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						 </aside>

		</div>

	</div>	

</div> <!-- end #cb-content -->
            <span id="cb-alp-loader" class="cb-alp-ld"><i class="fa fa-circle-o-notch fa-3x fa-fw"></i><span class="cb-end">No more articles</span></span>
            
				</div> <!-- end #cb-container -->
    			
    			<footer id="cb-footer">

                            				<div id="cb-widgets" class="cb-footer-x cb-footer-a wrap clearfix cb-site-padding">

                                                                                        <div class="cb-two cb-column clearfix">
                                    <div id="cb-recent-posts-3" class="cb-footer-widget clearfix cb-widget-latest-articles">
    		<div class="cb-module-block cb-small-margin">
    		                <article class="cb-looper cb-article clearfix cb-article-small  cb-separated">
                    <div class="cb-mask cb-img-fw" >
                        <a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/"><img width="100" height="65" src="https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-100x65.png" class="attachment-cb-100-65 size-cb-100-65 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/twittermilkpunch-759x500.png 759w" sizes="(max-width: 100px) 100vw, 100px" /></a>                                            </div>
                    <div class="cb-meta cb-article-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/the-cocktease-the-milk-punch-at-krio/">The Cocktease: The Milk Punch at Krio.</a></h4>
                        <div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div>                    </div>
                                    </article>
    		                <article class="cb-looper cb-article clearfix cb-article-small  cb-separated">
                    <div class="cb-mask cb-img-fw" >
                        <a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/"><img width="100" height="65" src="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-100x65.jpg" class="attachment-cb-100-65 size-cb-100-65 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-100x65.jpg 100w, https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-260x170.jpg 260w, https://www.centraltrack.com/wp-content/uploads/2016/12/dumpsterfire-759x500.jpg 759w" sizes="(max-width: 100px) 100vw, 100px" /></a>                                            </div>
                    <div class="cb-meta cb-article-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/the-biggest-dallas-asshats-of-2020/">The Biggest Dallas Asshats Of 2020.</a></h4>
                        <div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div>                    </div>
                                    </article>
    		                <article class="cb-looper cb-article clearfix cb-article-small  cb-separated">
                    <div class="cb-mask cb-img-fw" >
                        <a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/"><img width="100" height="65" src="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-100x65.png" class="attachment-cb-100-65 size-cb-100-65 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/09/THUNDERBIRD-2-759x500.png 759w" sizes="(max-width: 100px) 100vw, 100px" /></a>                                            </div>
                    <div class="cb-meta cb-article-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/the-best-new-dallas-bars-of-2020/">The Best New Dallas Bars Of 2020.</a></h4>
                        <div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div>                    </div>
                                    </article>
    		                <article class="cb-looper cb-article clearfix cb-article-small  cb-separated">
                    <div class="cb-mask cb-img-fw" >
                        <a href="https://www.centraltrack.com/song-of-the-day-the-avalanches-interstellar-love-feat-leon-bridges/"><img width="100" height="65" src="https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-100x65.png" class="attachment-cb-100-65 size-cb-100-65 wp-post-image" alt="" srcset="https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-100x65.png 100w, https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-260x170.png 260w, https://www.centraltrack.com/wp-content/uploads/2020/12/INTERSTELLAR-759x500.png 759w" sizes="(max-width: 100px) 100vw, 100px" /></a>                                            </div>
                    <div class="cb-meta cb-article-meta">
                        <h4 class="cb-post-title"><a href="https://www.centraltrack.com/song-of-the-day-the-avalanches-interstellar-love-feat-leon-bridges/">Song Of The Day: The Avalanches – &#8220;Interstellar Love Feat. Leon Bridges&#8221;</a></h4>
                        <div class="cb-byline cb-byline-short cb-byline-date"><span class="cb-date"><time class="entry-date updated" datetime="2020-12-22">December 22, 2020</time></span></div>                    </div>
                                    </article>
    		    		</div>
    		</div>                                    </div>
                                                                                        <div class="cb-three cb-column clearfix">
                                    <div id="bsa-block-300--250" class="bsaProContainerNew bsaProContainer-9 bsa-block-300--250 bsa-pro-col-2" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=9&bsa_pro_id=1174&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bsa-pro-upload/1590130330-shit-happens-side-bar-ad-v4_600.png&#39;)"></div></a></div></div></div></div><div class="bsaProItem " data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.centraltrack.com/ad-dashboard/?sid=9&bsa_pro_id=1178&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.centraltrack.com/wp-content/uploads/bsa-pro-upload/1592522061-BentonWilliams_600x500.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "9";
					var object = $(".bsaProContainer-" + sid);
					var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "250";
					var objectWidth = object.parent().outerWidth();
//					var objectWidth = object.width();
					if ( objectWidth <= parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							imageThumb.height(parentHeight * scale);
//							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
//							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						imageThumb.height(parentHeight);
//						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-9 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-9');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						                                </div>
                                                        
                        </div>

                    
                     
                    
                        <div class="cb-footer-lower cb-font-header clearfix">

                            <div class="wrap clearfix">

                            	                                    <div id="cb-footer-logo">
                                        <a href="https://www.centraltrack.com">
                                            <img src="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-Round-Logo.png" alt=" logo"  data-at2x="https://www.centraltrack.com/wp-content/uploads/2016/07/CT-FOOTER_retina_360.png">
                                        </a>
                                    </div>
                                
                                <div class="cb-footer-links clearfix"><ul id="menu-footer-menu" class="nav cb-footer-nav clearfix"><li id="menu-item-116158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-116158"><a href="https://www.centraltrack.com/">Home</a></li>
<li id="menu-item-116160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116160"><a href="https://www.centraltrack.com/contact/">Contact</a></li>
<li id="menu-item-116161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-116161"><a href="https://www.centraltrack.com/legal/">Legal</a></li>
<li id="menu-item-116159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116159"><a href="https://www.centraltrack.com/advertise/">Advertise</a></li>
<li id="menu-item-116163" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116163"><a href="https://www.centraltrack.com/about/">About</a></li>
<li id="menu-item-116162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116162"><a href="https://www.centraltrack.com/staff/">Staff</a></li>
</ul></div>
                                <div class="cb-copyright">COPYRIGHT 2020 CENTRAL TRACK</div>

                                		                            <div class="cb-to-top"><a href="#" id="cb-to-top"><i class="fa fa-angle-up cb-circle"></i></a></div>
		                        
           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

		</div> <!-- end #cb-outer-container -->

		<span id="cb-overlay"></span>
        <input type="hidden" id="_zinenonce" name="_zinenonce" value="c1ff604432" /><input type="hidden" name="_wp_http_referer" value="/the-biggest-dallas-asshats-of-2020/" />		            <script type="text/javascript">
              (function() {
                var sa = document.createElement('script'); sa.type = 'text/javascript'; sa.async = true;
                sa.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'cdn.ywxi.net/js/1.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sa, s);
              })();
            </script>	<div style="display:none">
	<div class="grofile-hash-map-10033ce5a7e39632b6c7c4b9821637b8">
	</div>
	</div>
	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type="text/javascript">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</script><script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.centraltrack.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"7.43.4"};
/* ]]> */
</script>
<script async defer id="hs-script-loader" type='text/javascript' src='//js.hs-scripts.com/2818223.js?integration=WordPress'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.centraltrack.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_f714af0d6e430f7c9f6886f2bffa0fd4","fragment_name":"wc_fragments_f714af0d6e430f7c9f6886f2bffa0fd4","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.5.2'></script>
<script type='text/javascript'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
	
</script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LdvuoIUAAAAAJ-qKFCiWsxWjYtmR8b7ZWD6Nf3B&#038;ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LdvuoIUAAAAAJ-qKFCiWsxWjYtmR8b7ZWD6Nf3B","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/www.centraltrack.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/www.centraltrack.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.centraltrack.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":"6LfN3YgUAAAAAOin6z0Z6z9T5VIEfWP7TlPqL65a"},"reCaptchaV2Invisible":{"siteKey":""},"facebook":{"appId":""},"google":{"clientId":""}},"captchaParams":{"imgPath":"https:\/\/www.centraltrack.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/www.centraltrack.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","answerForOtherTooLong":"The answer you have provided is too long","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.1.9.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/themes/15zine/library/js/cookie.min.js?ver=3.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbExt = {"cbLb":"on"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/themes/15zine/library/js/cb-ext.js?ver=3.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbScripts = {"cbUrl":"https:\/\/www.centraltrack.com\/wp-admin\/admin-ajax.php","cbPostID":"222670","cbFsClass":"cb-embed-fs","cbSlider":["600",true,"7000",true],"cbALlNonce":"619758ae8e","cbPlURL":"https:\/\/www.centraltrack.com\/wp-content\/plugins","cbShortName":null};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-content/themes/15zine/library/js/cb-scripts.min.js?ver=3.2.2'></script>
<script type='text/javascript' src='https://www.centraltrack.com/wp-includes/js/wp-embed.min.js?ver=5.4.4'></script>
<!-- WooCommerce JavaScript -->
<script type="text/javascript">
jQuery(function($) { 

			$( '.add_to_cart_button:not(.product_type_variable, .product_type_grouped)' ).click( function() {
				_gaq.push(['_trackEvent', 'Products', 'Add to Cart', ($(this).data('product_sku')) ? ($(this).data('product_sku')) : ('#' + $(this).data('product_id'))]);
			});
		
 });
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202052.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'114560379',post:'222670',tz:'-6',srv:'www.centraltrack.com'} ]);
	_stq.push([ 'clickTrackerInit', '114560379', '222670' ]);
</script>

	</body>

</html> <!-- The End. what a ride! -->
<!-- Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com -->
